Version 1.3.0

This update of Substance 3D Stager adds a new triplanar projection workflow for material application, a sample scene for showcasing material assets, and many enhancements.



Triplanar projection

Triplanar projection is a method of applying materials to objects without relying on UV systems. The material is projected onto the surface of the model from three planes (X, Y, and Z axis).  Triplanar support in Stager adds a new, versatile way of applying materials and even supports physical units for materials like fabrics that should maintain a real world appearance across objects.

Learn more about the triplanar projection feature.

Material showcase sample scene

The Substance 3D apps have been a long time favorite for material artists throughout many industries.  Stager now comes with a sample material scene for showcasing material assets. Access the new sample scene under File > Open sample > Material showcase.  With the ability to quickly send your materials from Sampler and Designer into Stager, it's now faster than ever to create quick material showcase scenes.



Map multiple textures to material channels

Importing multiple textures into a material takes time to drag-n-drop or browse for each channel.  Now you can map multiple textures at once by selecting images for each input channel or even setup keywords to automatically map images in a directory.

Access this new feature under the menu Object > Load material textures or in the Project materials panel context menu.



Enhancements

Export materials as MDL format

You can now export materials in MDL format.  Substance materials will be baked at their current parameters.  MDL can be re-imported into Stager, allowing you to save the appearance of a material for re-use across projects.  SBSAR format is planned for the future. 

This function works both for selections of materials in the Project materials panel or for selections of objects.  If objects are selected, all materials on the objects will be exported.


Access this feature under File > Export > Selected materials.

Hide interface

You can now choose to toggle the entire interface off, allowing you to use Stager in a clean presentation mode.  Tools and actions will continue to function so you can navigate the camera or make selections to highlight objects.


Access this feature under Window > Show/hide interface.

Filter scene panel

The scene panel can now be filtered by asset type to help find assets in large scenes.


Release Notes

1.3.2

(Released December 13, 2022)
Summary : Bug fix release.

Fixed:

  • [Crash] Fixed an issue where Stager was crashing at launch due to incorrectly trying to force discrete GPU use.
  • [GPU rendering] Fixed an issue where Stager was marking GPU rendering as unavailable when it should have been enabled.
  • [Publish] Fixed an issue where some users were unable to publish their 3D scenes to the web comment & review experience.
  • [Cameras] Fixed an issue where switching cameras lost the cameras previous transform data, causing it to move.
  • [Decals] Fixed an issue where decals could not be added to models in groups or hierarchies.
  • [Crash] Fixed an issue where Stager crashed when using undo after converting parametric models to standard models.
  • [Crash] Fixed an issue where Stager crashed when using cut/paste on some models.

Added:

  • [UI] Added the ability to right-click materials and decals to rename them in the Properties panel > Material tab when viewing an objects material list.
  • [Technical] Added an environment variable SUBSTANCE_DISABLE_SPECIFIC_FEATURES. Running Stager with this environment variable will disable hyperlinks and onboarding content.

Changed:

  • [Substance Models] Updated the Substance SDK to 2.0.2 to support the latest parametric models created in Substance 3D Designer.



1.3.1

(Released November 01, 2022)
Summary : Bug fix release.


Changed:

  • [Import] Updated SKP import support to Sketchup SDK 2022 version

Fixed:

  • [CC Libraries] Fixed an issue where images used from CC Libraries wouldn't update after being updated.
  • [Localization] The axis indicator in the viewport now has localized strings for it's tooltips.



1.3.0

(Released October 06, 2022)
Summary : Triplanar projections and various enhancements.


Added:

  • [Materials] Triplanar projection for materials added. Initial implementation includes global and local orientation.
  • [Materials] Triplanar projection support for physical units added.
  • [Materials] Added the ability to map multiple textures to materials by channel.
  • [Materials] Added the ability to use keywords to automatically map multiple textures from a directory.
  • [Materials] Importing SBSAR materials with height scale and height level settings will no longer disable those from being edited in the Stager interface.
  • [Export] Added the ability to export materials in MDL format.
  • [Assets] Added a new sample scene for showcasing materials.
  • [Interface] Added new Welcome modal that will show on first launch to introduce Stager.
  • [Interface] Added new What's new modal that will show on each release to introduce new features.
  • [Interface] Added an action to show/hide the interface. Menus and header bar will remain visible.
  • [Interface] Added the ability to filter the scene panel by asset type (model, light, camera).
  • [Interface] Added a new right-click context menu in the viewport for some functions.
  • [Interface] Added a close button to the color picker window.
  • [Cameras] Undo/redo added for all camera objects (previously only worked for viewport camera).
  • [Cameras] Added cameras to marquee selection functions for quick selection.
  • [Cameras] Cameras now work with the frame function to quickly view camera objects.
  • [Cameras] Updated framing logic. Framing will now only frame geometry if nothing is selected. If selection includes lights or cameras, those will be included in the frame action.
  • [Cameras] Added new framing actions to frame only geometry or non-geometry assets regardless of selection state.
  • [Rendering] Improved the default render save location. Previously always defaulted to desktop. Now will default to the saved location of the Stager file, if saved and remembers custom locations if set.

Fixed:

  • [Rendering] Resolved an issue where the real time rendering engine was slightly darker on Windows than Mac, resulting in inconsistent render results.
  • [Rendering] Resolved an issue where rendering multiple cameras of different resolutions could cause background images to become distorted or cropped.
  • [Interface] Resolved an issue where using depth of field could make render mode interface not load correctly.
  • [Interface] Resolved an issue where the gizmos were sometimes getting clipped.
  • [Crash] Fixed a crash that occurred when using Match Image.
  • [Crash] Fixed a crash when duplicating objects that had images applied in fill mode.
  • [Crash] Fixed a crash when using a negative value for opacity. This is unsupported and the UI no longer allows negative values.