The main toolbar

This page describes the Main toolbar and menu of Adobe Substance 3D Designer, which appear at the top left of the main window.It consists of two parts: the drop-down main menus, and quick-access buttons. All quick access button functions can also be accessed through the File and Edit menu's.



Quick access buttons

  • New Substance graph...  Ctrl+N  - Presents you the New Substance graph window, then creates a new package with a Substance graph.
  • New Substance model graph - creates a new package with a new Substance model graph.
  • New MDL graph... - Presents you the "New MDL graph" window, then creates a new package with a MDL graph.
  • Open... - Ctrl+O - Open an existing Substance package (.SBS, .SBSAR, .SBSASM).
  • Save All - Ctrl+Shift+S - Saves all open Substances and packages.
  • Undo Ctrl+Z - Undo last operation.
  • Redo Ctrl+Y - Redo last undone operation.


File menu

  • New - opens a sub menu to create a graph or package:
  • Open...  - Ctrl+O - Open an existing Substance package (.SBS, .SBSAR, .SBSASM)
  • Recent packages  - Displays a list of recently opened packages. Click on an entry to open it
  • Open last session packages (#) - Opens all packages that were open when the last session closed or was ended
  • Save all  - Ctrl+Shift+S - Saves all open packages, including packages loaded in the background
  • Close all - Closes all open packages
  • Reload resources  - Forces Designer to reload all resources, including bitmaps and SVG data
  • Exit - Ctrl+Q Close Substance 3D Designer


Edit menu

  • Undo - Ctrl+Z - Undo last operation.
  • Redo - Ctrl+Y - Redo last undone operation.
  • Preferences... - Opens the Preferences Window. This dialog is accessed from the Substance 3D Designer menu on OS X.


Tools menu

  • Cancel rendering - Esc - Stops current operation for the Substance Engine. Can be used to abort an unwanted, heavy operation.
  • Suspend engine  - Shift+Esc - Suspends the rendering engine. This can speed up editing of complex Substance graphs.
  • Switch engine...  - F9 - Offers a choice of rendering engines, including DirectX engines (Windows) and OpenGL (OS X) as well as the CPU software ("SSE") engine.
  • Substance Player - Manage Designer's integration with Substance Player 
    • Locate Player...  - Let Designer where Player is installed
    • Download Player... - Opens the Substance Player documentation's landing page, where Player can be downloaded
  • Plugin Manager... - Opens the Plugin Manager window, where you can install, load and unload Python Plugins for Substance 3D Designer.


Windows menu

To learn more about Designer's panel management, its customisation and workflow-enhancing features, go to the Customizing your workspace page of this documentation.
  • New Explorer  - Opens a new Explorer tab. You can have multiple Explorers open.
  • New 3D View  - Opens a new 3D View tab. You can Have Multiple 3D Views open.
  • New Library View - Opens a new Library tab. You can have multiple Libraries open.
  • Python Editor - Opens the Python Editor used to evaluate and create scripts.
  • Reset layout  - Resets the workspace to the default layout. All windows will be re-arranged, and some windows might be hidden again. Use in case of problems with program layout.
  • Unmaximize window - When any panel is maximized, this option unmaximizes it and restores the layout as it was before the window was maximized
  • Explorer - Show / hide the Explorer Window(s).
  • Graph  - Show / hide the graph Window(s).
  • Parameters - Show / hide the Properties Window.
  • Console - Show/Hide the Console Window.
  • 3D View - Show / hide the 3D View(s).
  • Dependency Manager - Show/Hide the Dependency Manager.
  • 2D Views - Show / hide the 2D View(s).
  • Library  - Show / hide the Library Window.
  • Main toolbar - Show / hide the Main Toolbar (quick-access buttons only).


Help menu

  • Tutorials - Opens free tutorials website (formerly Substance Academy).
  • Release notes - Opens a window with latest version's changelog.
  • Technical requirements - Shows you the technical requirements to run the application.
  • Documentation - Opens your default webbrowser on https://docs.substance3d.com/ for reference and technical documentation.
  • Scripting documentation - Opens your webbrowser on the local Python API docs.
  • Forums... - Opens your web browser on https://forum.substance3d.com/, to get in touch with the community and ask questions.
  • Report a bug... - Open bug reporting window.
  • Export log... - Exports current log files to a compressed (.zip) file, to provide to technical support.
  • Give feedback... - Opens your web browser on the Substance 3D Designer uservoice feedback page.
  • Substance 3D assets - Browse premium 3D content for subscribers (formerly Substance Source).
  • Substance 3D community assets - Lets you browse free community assets (formerly Substance Share).
  • (Adobe Substance 3D subscriptions only) Manage my account- Opens the webpage for your Adobe account
  • (Adobe Substance 3D subscriptions only) Sign in/Sign out... - Lets you sign into/out of your Adobe account
  • Welcome screen - Displays the Welcome dialog
  • About Substance 3D Designer... - Displays information about the application, like version number.
  • Partners - Lets you access the disclaimers and notices for third-party integrations from our partners in Designer